Home » Developer & Programmer » Reports & Discoverer » Barcode not showed to execute reports to printer. File .eps (Oracle Forms 12.2.1.4. Oracle Weblogic 12.2.1.4. Oracle Reports 12.2.1.3, Oracle Linux 8)
Barcode not showed to execute reports to printer. File .eps [message #684893] Wed, 22 September 2021 06:12 Go to next message
Goldaxe
Messages: 36
Registered: September 2019
Member
Hi,

I run a report that has barcode from a form and it does not show me the barcode. The output file is .eps
Data environment:
Oracle weblogic 12.2.1.4
Oracle Forms. 12.2.1.4
Oracle Reports: 12.2.1.3

The report font to barcode is CODE128.TTF

This font code128.ttf is in "/opt/oracle/Middleware/Oracle_Home/user_projects/domains/base_domain/reports/fonts" path

When report is run in report builder barcode is shown, but when I call this report from Form OR run it directly in browser barcode does not show.

The report is PDF. I do not see the barcode.


The .eps file is:
Thanks,
Iker

[Updated on: Wed, 22 September 2021 14:03] by Moderator

Report message to a moderator

Re: Barcode not showed to execute reports to printer. File .eps [message #684899 is a reply to message #684893] Wed, 22 September 2021 14:04 Go to previous messageGo to next message
Littlefoot
Messages: 21690
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
If you see barcode on your own PC (when developing that report), it means that barcode font is installed on the PC.

Is it installed on application (weblogic) server as well? If not, it must be.
Re: Barcode not showed to execute reports to printer. File .eps [message #684900 is a reply to message #684899] Thu, 23 September 2021 01:02 Go to previous message
Goldaxe
Messages: 36
Registered: September 2019
Member
I can see the barcode on my PC because the font is installed on windows but when I call this report from Form OR run it directly in browser barcode does not show.

The report font to barcode is CODE128.TTF

This font code128.ttf is in "/opt/oracle/Middleware/Oracle_Home/user_projects/domains/base_domain/reports/fonts" path.

I do not know if I should install it in more place or if I am missing something. Could you help me?
Previous Topic: Reverse print Issue
Next Topic: Union
Goto Forum:
  


Current Time: Fri Nov 26 20:15:45 CST 2021