Home » RDBMS Server » Server Administration » DISK_ASYNCH_IO=TRUE, FILESYSTEMIO_OPTIONS=SETALL but v$iostat.file=ASYNC_OFF (Oracle 19.3)
DISK_ASYNCH_IO=TRUE, FILESYSTEMIO_OPTIONS=SETALL but v$iostat.file=ASYNC_OFF [message #684370] Fri, 21 May 2021 13:50 Go to next message
burkinaone
Messages: 10
Registered: October 2020
Junior Member
Hello.
DB is Oracle 19.3 on RHEL 7.9
ASM

I have this:
DISK_ASYNCH_IO=TRUE
FILESYSTEMIO_OPTIONS=SETALL

But when I run this query, I get ASYNC_OFF for all the rows:
SELECT d.name,
i.asynch_io
FROM v$datafile d,
v$iostat_file i
WHERE d.file# = i.file_no
AND i.filetype_name = 'Data File';

Trying to find out why.
Thanks for your responses.
Re: DISK_ASYNCH_IO=TRUE, FILESYSTEMIO_OPTIONS=SETALL but v$iostat.file=ASYNC_OFF [message #684377 is a reply to message #684370] Sat, 22 May 2021 01:16 Go to previous messageGo to next message
John Watson
Messages: 8576
Registered: January 2010
Location: Global Village
Senior Member
Those parameters are not relevant when using ASM.
Re: DISK_ASYNCH_IO=TRUE, FILESYSTEMIO_OPTIONS=SETALL but v$iostat.file=ASYNC_OFF [message #684380 is a reply to message #684377] Sat, 22 May 2021 20:35 Go to previous messageGo to next message
burkinaone
Messages: 10
Registered: October 2020
Junior Member
My questions are:
1. Does having ASYNC_OFF when running this query mean IOs are nor async for these file?

2. What should I change at ASM level or DB level to have ASYNC_ON for these parameters?

Thanks for your replies.
Re: DISK_ASYNCH_IO=TRUE, FILESYSTEMIO_OPTIONS=SETALL but v$iostat.file=ASYNC_OFF [message #684384 is a reply to message #684380] Sun, 23 May 2021 06:55 Go to previous messageGo to next message
EdStevens
Messages: 1330
Registered: September 2013
Senior Member
burkinaone wrote on Sat, 22 May 2021 20:35
My questions are:
1. Does having ASYNC_OFF when running this query mean IOs are nor async for these file?

2. What should I change at ASM level or DB level to have ASYNC_ON for these parameters?

Thanks for your replies.
What part of "not relevant when using ASM." are you having difficulty with?

ASM Inherently Performs Asynchronous I/O Regardless of filesystemio_options Parameter (Doc ID 751463.1)
Re: DISK_ASYNCH_IO=TRUE, FILESYSTEMIO_OPTIONS=SETALL but v$iostat.file=ASYNC_OFF [message #684389 is a reply to message #684384] Sun, 23 May 2021 12:39 Go to previous messageGo to next message
burkinaone
Messages: 10
Registered: October 2020
Junior Member
I have 2 databases on ASM with the same parameters (DISK_ASYNCH_IO=TRUE, FILESYSTEMIO_OPTIONS=SETALL).
One has ASYNC_ON, the other has ASYNC_OFF. I am trying to understand what makes this difference.
If you are not felling unswering you just don't answer.
Re: DISK_ASYNCH_IO=TRUE, FILESYSTEMIO_OPTIONS=SETALL but v$iostat.file=ASYNC_OFF [message #684391 is a reply to message #684389] Sun, 23 May 2021 13:34 Go to previous messageGo to next message
burkinaone
Messages: 10
Registered: October 2020
Junior Member
If you don't know the answer, just don't reply. Is it that complicated?
Re: DISK_ASYNCH_IO=TRUE, FILESYSTEMIO_OPTIONS=SETALL but v$iostat.file=ASYNC_OFF [message #684392 is a reply to message #684391] Sun, 23 May 2021 14:10 Go to previous messageGo to next message
Michel Cadot
Messages: 67918
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator

A priori, if he gave you the link to the official answer from Oracle, he does know the answer which is the best and definitive answer, imho, and it could be fair to thank him instead of being rude.
It does not seem to me this kind of behavior will lead to some other help for you in the future.

[Updated on: Sun, 23 May 2021 14:11]

Report message to a moderator

Re: DISK_ASYNCH_IO=TRUE, FILESYSTEMIO_OPTIONS=SETALL but v$iostat.file=ASYNC_OFF [message #684401 is a reply to message #684392] Tue, 25 May 2021 09:13 Go to previous message
burkinaone
Messages: 10
Registered: October 2020
Junior Member
I found it is bug 30594167. Knowledge doesn't make noise.
Previous Topic: db_32k_cache_size RHEL
Next Topic: can select on dba_segments view but throwing error when using on a package
Goto Forum:
  


Current Time: Fri Jul 23 11:45:48 CDT 2021