Home » Infrastructure » Linux » Missing Package: gcc-c++-3.4.6 (x86_64) (Oracle 11g on Redhat Linux 6.2)
Missing Package: gcc-c++-3.4.6 (x86_64) [message #683814] Tue, 23 February 2021 01:18 Go to next message
Pablo030781
Messages: 7
Registered: February 2021
Junior Member
Package: gcc-c++-3.4.6 (x86_64) - This is a prerequisite condition to test whether the package "gcc-c++-3.4.6 (x86_64)" is available on the system.
Expected Value
 : gcc-c++(x86_64)-3.4.6
Actual Value
 : missing
 Details:
 - 
PRVF-7532 : Package "gcc-c++(x86_64)" is missing on node "localhost"  - Cause:  A required package is either not installed or, if the package is a kernel module, is not loaded on the specified node.  - Action:  Ensure that the required package is installed and available.
Re: Missing Package: gcc-c++-3.4.6 (x86_64) [message #683817 is a reply to message #683814] Tue, 23 February 2021 01:59 Go to previous messageGo to next message
Michel Cadot
Messages: 68042
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator

So what is the question?

Re: Missing Package: gcc-c++-3.4.6 (x86_64) [message #683818 is a reply to message #683817] Tue, 23 February 2021 02:20 Go to previous messageGo to next message
Pablo030781
Messages: 7
Registered: February 2021
Junior Member
Hi Michel,

I need to know which specific file
  • Attachment: gcc11g.png
    (Size: 206.60KB, Downloaded 295 times)
Re: Missing Package: gcc-c++-3.4.6 (x86_64) [message #683819 is a reply to message #683817] Tue, 23 February 2021 02:33 Go to previous messageGo to next message
Pablo030781
Messages: 7
Registered: February 2021
Junior Member
Can i install higher version of the package?

[root@localhost packages]# ll gcc-c++-*
-rwxrwxrwx. 1 root root 2485844 Aug 11 2005 gcc-c++-3.4.4-2.i386.rpm
-rwxrwxrwx. 1 root root 2862883 Jun 4 2008 gcc-c++-3.4.6-3.x86_64.rpm
-rwxrwxrwx. 1 root root 2865056 Mar 10 2007 gcc-c++-3.4.6-8.x86_64.rpm
-rwxrwxrwx. 1 root root 4955124 Aug 10 2015 gcc-c++-4.4.6-3.el6.x86_64.rpm
-rwxrwxrwx. 1 root root 4958176 May 14 2012 gcc-c++-4.4.6-4.el6.x86_64.rpm
[root@localhost packages]# rpm -ivh gcc-c++-3.4.6-8.x86_64.rpm
warning: gcc-c++-3.4.6-8.x86_64.rpm: Header V3 DSA/SHA1 Signature, key ID db42a60e: NOKEY
error: Failed dependencies:
gcc = 3.4.6-8 is needed by gcc-c++-3.4.6-8.x86_64
libstdc++-devel = 3.4.6 is needed by gcc-c++-3.4.6-8.x86_64
gcc-c++ < 4.0.0 conflicts with binutils-2.20.51.0.2-5.34.el6.x86_64
[root@localhost packages]#
Re: Missing Package: gcc-c++-3.4.6 (x86_64) [message #683820 is a reply to message #683819] Tue, 23 February 2021 02:47 Go to previous messageGo to next message
John Watson
Messages: 8640
Registered: January 2010
Location: Global Village
Senior Member
That is a warning, not an error. So you can ignore it if you want to.

Have you installed the Oracle Validated rpm? That should fix all such issues.
Re: Missing Package: gcc-c++-3.4.6 (x86_64) [message #683823 is a reply to message #683820] Tue, 23 February 2021 03:31 Go to previous messageGo to next message
Pablo030781
Messages: 7
Registered: February 2021
Junior Member
Hi John,

This is what i got when i tried installing.

warning: gcc-c++-3.4.6-8.x86_64.rpm: Header V3 DSA/SHA1 Signature, key ID db42a60e: NOKEY
error: Failed dependencies:
gcc = 3.4.6-8 is needed by gcc-c++-3.4.6-8.x86_64
libstdc++-devel = 3.4.6 is needed by gcc-c++-3.4.6-8.x86_64
gcc-c++ < 4.0.0 conflicts with binutils-2.20.51.0.2-5.34.el6.x86_6
Re: Missing Package: gcc-c++-3.4.6 (x86_64) [message #683824 is a reply to message #683823] Tue, 23 February 2021 03:58 Go to previous messageGo to next message
John Watson
Messages: 8640
Registered: January 2010
Location: Global Village
Senior Member
Quote:
That is a warning, not an error. So you can ignore it if you want to.

Have you installed the Oracle Validated rpm? That should fix all such issues.
Re: Missing Package: gcc-c++-3.4.6 (x86_64) [message #683841 is a reply to message #683824] Tue, 23 February 2021 09:10 Go to previous messageGo to next message
Pablo030781
Messages: 7
Registered: February 2021
Junior Member
Hi John,

I ignored it the error below appeared:

Error in invoking target 'mkldflags ntcontab.o nnfgt.o' of makefile '/u01/app/oracle/product/11.2.0/db_1/network/lib/ins_net_client.mk'. See '/u01/app/oraInventory/logs/installActions2021-02-23_02-26-58PM.log' for details.
Re: Missing Package: gcc-c++-3.4.6 (x86_64) [message #683848 is a reply to message #683841] Tue, 23 February 2021 09:53 Go to previous messageGo to next message
Pablo030781
Messages: 7
Registered: February 2021
Junior Member
It is installed already

[root@localhost packages]# rpm -qf /usr/bin/gcc
gcc-3.4.6-3.x86_64
[root@localhost packages]#

Re: Missing Package: gcc-c++-3.4.6 (x86_64) [message #683849 is a reply to message #683848] Tue, 23 February 2021 10:17 Go to previous messageGo to next message
John Watson
Messages: 8640
Registered: January 2010
Location: Global Village
Senior Member
Are you under the impression that C is the same as C++ ? Well, never mind - that was only a warning. So for the last time,
Quote:
Have you installed the Oracle Validated rpm? That should fix all such issues.
Re: Missing Package: gcc-c++-3.4.6 (x86_64) [message #683850 is a reply to message #683849] Tue, 23 February 2021 11:51 Go to previous messageGo to next message
Pablo030781
Messages: 7
Registered: February 2021
Junior Member
Hi John,

I used the rpm from the REDHAT 6.2 installer.
Re: Missing Package: gcc-c++-3.4.6 (x86_64) [message #683851 is a reply to message #683850] Tue, 23 February 2021 12:25 Go to previous message
John Watson
Messages: 8640
Registered: January 2010
Location: Global Village
Senior Member
You have not Googled "oracle validated rpm", have you? I guess you are not following the Installation Guide. It does have some helpful advice.
https://docs.oracle.com/cd/E11882_01/install.112/e47689/pre_install.htm#LADBI1090
Previous Topic: How to set backup automatically?
Next Topic: database configuration assistant failed to detect options for this oracle installation ora-12547: tn
Goto Forum:
  


Current Time: Mon Nov 29 06:22:16 CST 2021