Home » SQL & PL/SQL » SQL & PL/SQL » Try to execute operating system command - RPC Error
Try to execute operating system command - RPC Error [message #36138] Wed, 07 November 2001 07:13 Go to next message
CJ Jay
Messages: 1
Registered: November 2001
Junior Member
Hi
I have seen posting related to this before and I tried to experiment with some of the answers given in the forum .
I do not have lot experience in Oracle.
This is the error I am getting.

ORA-28575: unable to open RPC connection to external procedure agent
ORA-06512: at "SYSTEM.CPLSQL_SYSTEM", line 0
ORA-06512: at "SYSTEM.NEW_VIEW", line 5
ORA-06512: at "SYSTEM.NEWTRIGGER", line 2
ORA-04088: error during execution of trigger 'SYSTEM.NEWTRIGGER'

This is what I did.
1. created a Library from the SQL prompt as follows
SQL> create library clib as 'c:winntsystem32crtdll.dll' ;

it successfully created a library

2. Created a function to call this library as follows
SQL> CREATE OR REPLACE FUNCTION cplsql_system(cmd in varchar2)
RETURN BINARY_INTEGER
AS EXTERNAL LIBRARY clib
NAME "system";

it successfully created a function.

3. Created a Stored Procedure to call this function as follows.

SQL > create procedure new_view(cmd IN Varchar2)
AS
retval NUMBER;
begin
retval := cplsql_system( cmd );
end;

it successfully created a procedure.

4. Created a Trigger which calls the procedure created in the step 3. as follows
SQL> create trigger newtrigger after update on JEPS
for each row
begin
new_view('notepad');
end;

it successfully created a trigger for the table Jeps .

( Jeps is a table with two fields
seqno Number,
desc Varchar2(35)
)

5. For testing I inserted a record into JEPS and then tried to update it . But it gave me the errors mentioned in the beginning.

I have Windows NT system where the oracle client is installed and server is on another machine.

- Thanks for your time.

----------------------------------------------------------------------
Re: Try to execute operating system command - RPC Error [message #36198 is a reply to message #36138] Fri, 09 November 2001 06:30 Go to previous message
hello
Messages: 17
Registered: November 2001
Junior Member
Hi,
You must have tried this already but i guess it's kind of a listener problem.

If u go to Oracle Metalink and search for the first Oracle Error ORA-28575 there are few documents on this problem that can help you.

----------------------------------------------------------------------
Previous Topic: copy command inside a procedure
Next Topic: Droping Temporary Table
Goto Forum:
  


Current Time: Tue May 28 05:19:14 CDT 2024